Posts Tagged ‘detach bug’

The Detach Bug is fixed

Friday, June 19th, 2009

UPDATE February 20, 2010: The Detach Bug is now fixed. I have not been able to verify it happening since the fix was finally added to the server code late last summer.

A while back, I had reported that the Detach Bug had been fixed. For many months we have been waiting for the fix to be implemented in the official SL client. It’s finally been released and as best as I can surmise, the fix now prevents you from making copies of worn objects. This does indeed prevent the first reproduction of the bug, but it does nothing to fix the core problem. HUDs that are worn from the ground are still in danger of being lost when they are next detached or when you log out or crash.

How to prevent the Detach Bug

Never wear your HUD directly from the ground. Right click on the HUD and take it. Then wear it from your inventory.

Wearing objects from the ground may lead to inventory loss

Wearing objects from the ground may lead to inventory loss

What to do if you have lost a HUD or other detachment

You should do the usual things from the Second Life Wiki like clear your cache. But if that doesn’t work, contact Second Life support. Open a ticket on their website and ask for an inventory restart/fix. Explain that you have lost a HUD when it detached, that it disappeared from your inventory and that you have tried solutions from the wiki. They will help you, even if you are just a basic member. Their support might be faster if you are premium however.

Second Life support can help you! If you lost your HUD from the Detach Bug, they can almost always retrieve it using their inventory fix. Always contact support for this problem.

What else can you do?

Please take the time to log into the jira site (the official Second Life bug tracking system) and vote on this problem. The current jira issue for this problem is SVC-2956.

UPDATE (June 26): There is another well commented description of the same essential bug on the jira. Please vote for VWR-12525.

Detach Bug is fixed

Wednesday, January 7th, 2009

It appears that there is a fix for the Detach Bug that has plagued so many people this past year. It will probably take some time before it actually gets into the release build of the client. Still it’s good news to know this will soon be fixed.

Qarl Linden posted this on the jira:

sorry for all the grief. should be fixed when maint-viewer-12 reaches RC. until then, try to avoid copying worn objects, and wearing objects directly from the ground.